blob: f13940ce4f20d33a6eb5db0e905009e36402c157 [file] [log] [blame]
Patrick Williamsd849ec72016-08-17 14:59:38 -05001DESCRIPTION = "A Xen guest image."
2
3inherit core-image
4
5IMAGE_INSTALL += " \
6 packagegroup-core-boot \
7 ${@bb.utils.contains('MACHINE_FEATURES', 'acpi', 'kernel-module-xen-acpi-processor', '', d)} \
8 "
9
10IMAGE_INSTALL += "${@base_contains('DISTRO_FEATURES', 'x11', ' xf86-video-fbdev', '', d)}"
11IMAGE_INSTALL += "${@base_contains('DISTRO_FEATURES', 'x11', ' xf86-video-vesa', '', d)}"
12
13LICENSE = "MIT"
14
15# Send console messages to xen console
16APPEND += "console=hvc0"