blob: 1dfb199ff30016354815db50717cd2e068341ead [file] [log] [blame]
Andrew Geisslerc5535c92023-01-27 16:10:19 -06001SUMMARY = "LVGL Demo Application for Framebuffer"
2HOMEPAGE = "https://github.com/lvgl/lv_port_linux_frame_buffer"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=802d3d83ae80ef5f343050bf96cce3a4 \
5 file://lv_drivers/LICENSE;md5=d6fc0df890c5270ef045981b516bb8f2 \
6 file://lvgl/LICENCE.txt;md5=bf1198c89ae87f043108cea62460b03a"
7
8SRC_URI = "gitsm://github.com/lvgl/lv_port_linux_frame_buffer.git;branch=master;protocol=https"
Andrew Geissler3eeda902023-05-19 10:14:02 -05009SRCREV = "adf2c4490e17a1b9ec1902cc412a24b3b8235c8e"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060010
11S = "${WORKDIR}/git"
12
Andrew Geissler3eeda902023-05-19 10:14:02 -050013REQUIRED_DISTRO_FEATURES = "fbdev"
14
15inherit features_check
16
Andrew Geisslerc5535c92023-01-27 16:10:19 -060017EXTRA_OEMAKE = "DESTDIR=${D}"
18
19do_install() {
20 oe_runmake install
21}