Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Desktop containment framework." |
| 2 | HOMEPAGE = "http://flatpak.org" |
| 3 | LICENSE = "LGPL-2.1-only" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" |
| 5 | |
| 6 | SRC_URI = " \ |
| 7 | gitsm://github.com/flatpak/flatpak;protocol=https;nobranch=1 \ |
| 8 | file://0001-flatpak-pc-add-pc_sysrootdir.patch \ |
| 9 | " |
| 10 | |
| 11 | SRCREV = "47ea3934c0e055605b8dff93edad2136141e48ec" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | inherit meson pkgconfig gettext systemd gobject-introspection python3native useradd mime features_check |
| 16 | |
| 17 | REQUIRED_DISTRO_FEATURES = "polkit" |
| 18 | |
| 19 | DEPENDS = " \ |
| 20 | appstream \ |
| 21 | bison-native \ |
| 22 | curl \ |
| 23 | dconf \ |
| 24 | fuse3 \ |
| 25 | gdk-pixbuf \ |
| 26 | glib-2.0 \ |
| 27 | gpgme \ |
| 28 | json-glib \ |
| 29 | libarchive \ |
| 30 | libcap \ |
| 31 | libxslt-native \ |
| 32 | ostree \ |
| 33 | polkit \ |
| 34 | python3-pyparsing-native \ |
| 35 | xmlto-native \ |
| 36 | " |
| 37 | |
| 38 | RDEPENDS:${PN} = " \ |
| 39 | bubblewrap \ |
| 40 | ca-certificates \ |
| 41 | dconf \ |
| 42 | flatpak-xdg-utils \ |
| 43 | " |
| 44 | |
| 45 | GIR_MESON_OPTION = "" |
| 46 | |
| 47 | PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,xauth" |
| 48 | PACKAGECONFIG[xauth] = "-Dxauth=enabled,-Dxauth=disabled,xauth" |
| 49 | PACKAGECONFIG[seccomp] = "-Dseccomp=enabled,-Dseccomp=disabled,libseccomp" |
| 50 | |
| 51 | PACKAGECONFIG ?= " \ |
| 52 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xauth', '', d)} \ |
| 53 | ${@bb.utils.contains('DISTRO_FEATURES', 'security', 'seccomp', '', d)} \ |
| 54 | " |
| 55 | |
| 56 | FILES:${PN} += "${libdir} ${datadir}" |
| 57 | |
| 58 | USERADD_PACKAGES = "${PN}" |
| 59 | USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 polkitd" |
| 60 | |
| 61 | do_install:append() { |
| 62 | chmod 0700 ${D}/${datadir}/polkit-1/rules.d |
| 63 | chown polkitd ${D}/${datadir}/polkit-1/rules.d |
| 64 | chgrp root ${D}/${datadir}/polkit-1/rules.d |
| 65 | } |