Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "mailx is the traditional command-line-mode mail user agent" |
| 2 | |
| 3 | DESCRIPTION = "Mailx is derived from Berkeley Mail and is intended provide the \ |
| 4 | functionality of the POSIX mailx command with additional support \ |
| 5 | for MIME, IMAP, POP3, SMTP, and S/MIME." |
| 6 | |
| 7 | HOMEPAGE = "http://heirloom.sourceforge.net/mailx.html" |
| 8 | SECTION = "console/network" |
| 9 | LICENSE = "BSD & MPL-1" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=4202a0a62910cf94f7af8a3436a2a2dd" |
| 11 | |
| 12 | DEPENDS = "openssl" |
| 13 | |
| 14 | SRC_URI = "${DEBIAN_MIRROR}/main/h/heirloom-mailx/heirloom-mailx_12.5.orig.tar.gz;name=archive \ |
| 15 | file://0001-Don-t-reuse-weak-symbol-optopt-to-fix-FTBFS-on-mips.patch \ |
| 16 | file://0002-Patched-out-SSL2-support-since-it-is-no-longer-suppo.patch \ |
| 17 | file://0003-Fixed-Lintian-warning-warning-macro-N-not-defined.patch \ |
| 18 | file://0011-outof-Introduce-expandaddr-flag.patch \ |
| 19 | file://0012-unpack-Disable-option-processing-for-email-addresses.patch \ |
| 20 | file://0013-fio.c-Unconditionally-require-wordexp-support.patch \ |
| 21 | file://0014-globname-Invoke-wordexp-with-WRDE_NOCMD.patch \ |
| 22 | file://0015-usr-sbin-sendmail.patch \ |
| 23 | file://explicitly.disable.krb5.support.patch \ |
| 24 | " |
| 25 | |
| 26 | SRC_URI[archive.md5sum] = "29a6033ef1412824d02eb9d9213cb1f2" |
| 27 | SRC_URI[archive.sha256sum] = "015ba4209135867f37a0245d22235a392b8bbed956913286b887c2e2a9a421ad" |
| 28 | |
| 29 | S = "${WORKDIR}/heirloom-mailx-12.5" |
| 30 | |
| 31 | inherit autotools-brokensep |
| 32 | |
| 33 | CFLAGS_append = " -D_BSD_SOURCE -DDEBIAN -I${S}/EXT" |
| 34 | |
| 35 | # "STRIP=true" means that 'true' command will be used to 'strip' files which will achieve the effect of not stripping them |
| 36 | # mailx's Makefile doesn't allow a more straightforward way to avoid stripping |
| 37 | EXTRA_OEMAKE = "SENDMAIL=${sbindir}/sendmail IPv6=-DHAVE_IPv6_FUNCS PREFIX=/usr UCBINSTALL=/usr/bin/install STRIP=true" |
| 38 | |
| 39 | # The makeconfig can't run parallelly, otherwise the checking results |
| 40 | # might be incorrect and lead to errors: |
| 41 | # fio.c:56:17: fatal error: ssl.h: No such file or directory |
| 42 | # #include <ssl.h> |
| 43 | PARALLEL_MAKE = "" |