Potin Lai | 1a30877 | 2023-12-13 19:17:12 +0800 | [diff] [blame] | 1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
| 2 | |
| 3 | inherit obmc-phosphor-systemd |
| 4 | |
| 5 | SRC_URI:append = " \ |
| 6 | file://setup-uart-routing \ |
| 7 | file://setup-uart-routing.conf \ |
| 8 | " |
| 9 | |
| 10 | do_install:append() { |
| 11 | install -d ${D}${libexecdir}/${PN} |
| 12 | install -m 0755 ${WORKDIR}/setup-uart-routing ${D}${libexecdir}/${PN} |
| 13 | } |
| 14 | |
| 15 | SYSTEMD_OVERRIDE:${PN}:append = " setup-uart-routing.conf:obmc-console@ttyS2.service.d/setup-uart-routing.conf" |
| 16 | RDEPENDS:${PN}:append = " bash" |