blob: 5c0cfa4a28f288d13723cae726e8c69402c96517 [file] [log] [blame]
Joel Stanley34c894e2015-12-06 22:54:23 +10301SUMMARY = "pflash programmer for OpenPower"
2DESCRIPTION = "pflash firmware programming tool for OpenPower machines"
3HOMEPAGE = "https://github.com/open-power"
4LICENSE = "Apache-2.0"
5
6SRC_URI += "git://github.com/open-power/skiboot.git"
7LIC_FILES_CHKSUM = "file://${S}/LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57"
8
Joel Stanleycf4d1592016-04-28 14:05:49 +09309SRCREV = "skiboot-5.2.1"
10PV = "5.2.1"
Joel Stanley34c894e2015-12-06 22:54:23 +103011
12S = "${WORKDIR}/git"
13
14EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} PFLASH_VERSION=${PV} V=1'
15
16do_compile () {
17 oe_runmake -C external/pflash all
18}
19
20do_install () {
21 oe_runmake -C external/pflash install DESTDIR=${D}
22}