dbus-top: initial commits
This commit covers the basic functionalities of the dbus-top tool.
The UI is divided into 3 windows as follows:
+--------------------------+ Window list
| Window A | A: Summary statistics
+------------+-------------+ B: Sensor list or detail
| Window B | Window C | C: Detailed statistics
+------------+-------------+
To navigate the UI:
* Use tab to navigate each window
When a window is highlighted:
In Window B:
* Press esc key 3 times to leave the current sensor selection
In Window C:
* Press [Enter] to show/hide pop-up menu for column selectio
* Press [Left] to move highlight cursor to the left
* Press [Right] to move highlight cursor to the right
* Press [A] to sort by the highlighted column in ascending order
* Press [D] to sort by the highlighted column in descending order
To add recipe to Yocto and build the recipe:
1) Copy and paste the content of the .bb file into a folder that can be
detected by bitbake, such as meta-phosphor/recipes-phosphor/ipmi.
2) run "devtool modify -n dbus-top (path_to_openbmc_tools)/dbus-top/".
Signed-off-by: Adedeji Adebisi <adedejiadebisi01@gmail.com>
Change-Id: Id58ba30b815cfd9d18f54cf477d749dbdbc4545b
(cherry picked from commit d83c1aa45aa8cc9b61530b4f0fe1d04aa64d2c41)
diff --git a/dbus_top_recipe.bb b/dbus_top_recipe.bb
new file mode 100644
index 0000000..4de4f0e
--- /dev/null
+++ b/dbus_top_recipe.bb
@@ -0,0 +1,23 @@
+HOMEPAGE = "http://github.com/openbmc/openbmc-tools"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://../LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+SRC_URI += "git://github.com/openbmc-tools"
+SRCREV = "4a0e2e3c10327dac1c923d263929be9a20478b24"
+
+S = "${WORKDIR}/git/"
+inherit meson
+
+SUMMARY = "DBus-Top"
+DESCRIPTION = "DBUs-Top."
+GOOGLE_MISC_PROJ = "dbus-top"
+
+DEPENDS += "systemd"
+DEPENDS += "sdbusplus"
+DEPENDS += "phosphor-mapper"
+DEPENDS += "ncurses"
+
+inherit systemd