meta-amd: Add ipmi config, host and fru .bbappend files
This patch creates an empty DCMI sensors json file as EthanolX does not
define DCMI sensors. It also modifies phosphor-ipmi-fru and
phosphor-ipmi-host bitbake files to read the ipmi fru and sensors
configuration data from yaml files in configuration directory.
Change-Id: I2a77bf0a4a68d99d0c8dd91b29c1300fde9de5d4
Signed-off-by: Supreeth Venkatesh <supreeth.venkatesh@amd.com>
diff --git a/meta-ethanolx/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend b/meta-ethanolx/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
new file mode 100644
index 0000000..706e192
--- /dev/null
+++ b/meta-ethanolx/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
@@ -0,0 +1,6 @@
+DEPENDS_append_ethanolx = " ethanolx-yaml-config"
+
+EXTRA_OECONF_ethanolx = " \
+ YAML_GEN=${STAGING_DIR_HOST}${datadir}/ethanolx-yaml-config/ipmi-fru-read.yaml \
+ PROP_YAML=${STAGING_DIR_HOST}${datadir}/ethanolx-yaml-config/ipmi-extra-properties.yaml \
+ "