u-boot-aspeed: Fix fw_env.config for ast2600
The configuration was not set at all, leaving us with the default
configuration file from u-boot.
This sets it to the u-boot environment partition, /dev/mtd2.
Change-Id: Ic7439c057151763273b35435d0414adeac3ef76a
Signed-off-by: Joel Stanley <joel@jms.id.au>
diff --git a/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb b/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
index 59fdbde..8214579 100644
--- a/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
+++ b/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
@@ -5,6 +5,8 @@
PROVIDES += "u-boot-fw-utils"
+SRC_URI += "file://fw_env_ast2600_nor.config"
+
INSANE_SKIP_${PN} = "already-stripped"
EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
EXTRA_OEMAKE_class-cross = 'HOSTCC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
@@ -21,7 +23,7 @@
install -d ${D}${sysconfdir}
install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
- install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
+ install -m 644 ${WORKDIR}/fw_env_ast2600_nor.config ${D}${sysconfdir}/fw_env.config
}
do_install_class-cross () {