meta-facebook: obmc-console: Fix SoL with new design
With new design changes in obmc-console, config file needed changes
to follow design. Also created separate directorey for machine to
have machine specific config file.
Tested: Verified this with tiogapass and see ttyS2 service is launching.
Change-Id: I6150d6faf226eca47918e24693ed770be687472a
Signed-off-by: Vijay Khemka <vijaykhemka@fb.com>
diff --git a/recipes-phosphor/console/obmc-console_%.bbappend b/recipes-phosphor/console/obmc-console_%.bbappend
index 24b52d7..06a91ce 100644
--- a/recipes-phosphor/console/obmc-console_%.bbappend
+++ b/recipes-phosphor/console/obmc-console_%.bbappend
@@ -1,2 +1,13 @@
-FILESEXTRAPATHS_prepend_tiogapass := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/${MACHINE}:"
OBMC_CONSOLE_HOST_TTY = "ttyS2"
+
+SRC_URI += "file://*.conf"
+SRC_URI_remove = "file://${BPN}.conf"
+
+do_install_append() {
+ # Install the server configuration
+ install -m 0755 -d ${D}${sysconfdir}/${BPN}
+ install -m 0644 ${WORKDIR}/*.conf ${D}${sysconfdir}/${BPN}/
+ # Remove upstream-provided server configuration
+ rm -f ${D}${sysconfdir}/${BPN}/server.ttyVUART0.conf
+}