meta-ibm: witherspoon: inventory: target class recipes

In the near future meta-phosphor will switch phosphor-inventory-manager
over to target class configuration recipes in place of native class
configuration recipes.  Configuration recipes populate the
/usr/share/phosphor-inventory filesystem with the YAML configuration
that the phosphor-inventory-manager build process expects.

Those are preferable to native class config recipes because native
recipes cannot be overridden based on MACHINE.

Add a target class recipe for inventory-cleanup so meta-ibm is ready
when meta-phosphor makes the cut-over.

Change-Id: I5d3b3591da8d20186c4f8f3966f27db4d6ea6e97
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend b/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
index 5e3aff4..9b5b948 100644
--- a/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
+++ b/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
@@ -2,6 +2,9 @@
 PACKAGECONFIG_append = " associations"
 SRC_URI += "file://associations.json"
 
+
+DEPENDS_append_witherspoon = " inventory-cleanup"
+
 do_install_append() {
     install -d ${D}${base_datadir}
     install -m 0755 ${WORKDIR}/associations.json ${D}${base_datadir}/associations.json