dreport: Collect IBM error objects on IBM systems

Add a plugin for systems in the meta-ibm layer
to collect the com.ibm.Logging objects in a dump.

Resolves openbmc/openbmc#3043

Tested: Run dreport and check that the IBM data is there.

Change-Id: Iaa01a07633265c767649caaf8b9b1580f31ce7cd
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/recipes-phosphor/dump/phosphor-debug-collector.bbappend b/recipes-phosphor/dump/phosphor-debug-collector.bbappend
new file mode 100644
index 0000000..402e4fa
--- /dev/null
+++ b/recipes-phosphor/dump/phosphor-debug-collector.bbappend
@@ -0,0 +1,21 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://plugins.d/ibm_elogall"
+
+install_ibm_plugins() {
+
+    install -m 0755 ${WORKDIR}/plugins.d/ibm_elogall ${D}${dreport_plugin_dir}
+
+}
+
+#Link in the plugins so dreport run them at the appropriate time
+python link_ibm_plugins() {
+
+    workdir = d.getVar('WORKDIR', True)
+    script = os.path.join(workdir, 'plugins.d', 'ibm_elogall')
+    install_dreport_user_script(script, d)
+
+}
+
+do_install[postfuncs] += "install_ibm_plugins"
+do_install[postfuncs] += "link_ibm_plugins"