meta-ibm: Add mihawk ipmi yaml.

Add mihawk's ipmi sensor and fru yaml.

Tested: Use ipmi command to get the sensor list and fru data.

Signed-off-by: Ben Pai <Ben_Pai@wistron.com>
Change-Id: I2aec2e8beccad01eade77371d68ee3d420ff826b
diff --git a/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb b/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb
index d0dbd60..245693a 100644
--- a/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb
+++ b/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb
@@ -6,7 +6,7 @@
 inherit allarch
 inherit mrw-xml
 
-SRC_URI = " \
+SRC_URI_ibm-ac-server = " \
     file://acx22-ipmi-fru-bmc.yaml \
     file://acx22-ipmi-fru-not-sent-by-host.yaml \
     file://acx22-ipmi-hwmon-sensors.yaml \
@@ -14,7 +14,13 @@
     file://acx22-ipmi-occ-sensors.yaml \
     file://acx22-ipmi-sensors-mrw.yaml \
     "
-
+SRC_URI_mihawk = " \
+    file://acx22-ipmi-fru-bmc.yaml \
+    file://acx22-ipmi-hwmon-sensors.yaml \
+    file://acx22-ipmi-inventory-sensors.yaml \
+    file://acx22-ipmi-occ-sensors.yaml \
+    file://acx22-ipmi-sensors-mrw.yaml \
+    "
 DEPENDS = " \
     mrw-native \
     mrw-perl-tools-native \
@@ -23,10 +29,13 @@
 
 S = "${WORKDIR}"
 
-ACx22_IPMI_EXTRA_FRU_READ_YAMLS = " \
+ACx22_IPMI_EXTRA_FRU_READ_YAMLS_ibm-ac-server = " \
     acx22-ipmi-fru-bmc.yaml \
     acx22-ipmi-fru-not-sent-by-host.yaml \
     "
+ACx22_IPMI_EXTRA_FRU_READ_YAMLS_mihawk = " \
+    acx22-ipmi-fru-bmc.yaml \
+    "
 ACx22_IPMI_EXTRA_SENSOR_YAMLS = " \
     acx22-ipmi-hwmon-sensors.yaml \
     acx22-ipmi-occ-sensors.yaml \