mboxd: Only include check_pnor_format if ubi feature is enabled

The check_pnor_format checks if the PNOR is formatted as UBI,
so it should only be added if the UBI feature is enabled.

Change-Id: Ib1a295de290a9dec6735bd9a960074c702f8afd5
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
diff --git a/meta-witherspoon/recipes-phosphor/mboxd/mboxd_%.bbappend b/meta-witherspoon/recipes-phosphor/mboxd/mboxd_%.bbappend
index 589405e..9ead959 100644
--- a/meta-witherspoon/recipes-phosphor/mboxd/mboxd_%.bbappend
+++ b/meta-witherspoon/recipes-phosphor/mboxd/mboxd_%.bbappend
@@ -3,11 +3,11 @@
 
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
-SYSTEMD_SERVICE_${PN}_append_ibm-ac-server = " check-pnor-format.service"
+SYSTEMD_SERVICE_${PN}_append_df-openpower-ubi-fs = " check-pnor-format.service"
 
-SRC_URI_append_ibm-ac-server = " file://check_pnor_format.sh"
+SRC_URI_append_df-openpower-ubi-fs = " file://check_pnor_format.sh"
 
-do_install_append_ibm-ac-server() {
+do_install_append_df-openpower-ubi-fs() {
 	install -d ${D}${bindir}
 	install -m 0755 ${WORKDIR}/check_pnor_format.sh ${D}${bindir}/check_pnor_format.sh
 }