meta-ibm: phosphor-dbus-monitor non-native

Create the phosphor-dbus-monitor non-native recipes to allow the switch
from native to non-native within the meta-ibm layer. Upon switching to
the non-native recipe in meta-phosphor, these non-native recipes will
then replace the native recipes in providing the policy configuration
files(yaml).

Tested:
    Built witherspoon phosphor-dbus-monitor resulting in no image change

Change-Id: I3dae7dc3adcb5b930b22e8e678eadb94bd825ddc
Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
diff --git a/meta-witherspoon/recipes-phosphor/fans/witherspoon-thermal-policy.bb b/meta-witherspoon/recipes-phosphor/fans/witherspoon-thermal-policy.bb
new file mode 100644
index 0000000..ef395b1
--- /dev/null
+++ b/meta-witherspoon/recipes-phosphor/fans/witherspoon-thermal-policy.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Thermal policy for Witherspoon"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit allarch
+inherit phosphor-dbus-monitor
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+
+SRC_URI += "file://thermal-policy.yaml"
+
+do_install() {
+        install -D ${WORKDIR}/thermal-policy.yaml ${D}${config_dir}/thermal-policy.yaml
+}
+
+FILES_${PN} += "${config_dir}/thermal-policy.yaml"