meta-ibm: romulus: override variable assignments

Add overrides to variable assignments as described in "Modify Variables
to Support a Different Machine" in the yocto development tasks manual:
https://www.yoctoproject.org/docs/latest/dev-manual/dev-manual.html#best-practices-to-follow-when-creating-layers

In a nutshell this allows multiple BSP layers to be included
simultaneously in bblayers.conf, which increases the potential for meta
data sharing between layers.

Change-Id: Ifaddc5aa30ad9eb00a0242d38bc3a161551ffb95
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend b/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend
index 98b0810..072623e 100644
--- a/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend
+++ b/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend
@@ -1,11 +1,11 @@
-FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_append_romulus := "${THISDIR}/${PN}:"
 
 # Package configuration
 FAN_PACKAGES += " \
         phosphor-cooling-type \
 "
 
-PACKAGECONFIG += "cooling-type"
+PACKAGECONFIG_append_romulus = " cooling-type"
 
 TMPL_COOLING = "phosphor-cooling-type@.service"
 INSTFMT_COOLING = "phosphor-cooling-type@{0}.service"
@@ -18,5 +18,5 @@
 
 COOLING_ENV_FMT = "obmc/phosphor-fan/phosphor-cooling-type-{0}.conf"
 
-SYSTEMD_ENVIRONMENT_FILE_phosphor-cooling-type += "${@compose_list(d, 'COOLING_ENV_FMT', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_ENVIRONMENT_FILE_phosphor-cooling-type_append_romulus = " ${@compose_list(d, 'COOLING_ENV_FMT', 'OBMC_CHASSIS_INSTANCES')}"