meta-ibm: romulus: override variable assignments

Add overrides to variable assignments as described in "Modify Variables
to Support a Different Machine" in the yocto development tasks manual:
https://www.yoctoproject.org/docs/latest/dev-manual/dev-manual.html#best-practices-to-follow-when-creating-layers

In a nutshell this allows multiple BSP layers to be included
simultaneously in bblayers.conf, which increases the potential for meta
data sharing between layers.

Change-Id: Ifaddc5aa30ad9eb00a0242d38bc3a161551ffb95
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-romulus/recipes-phosphor/host/p9-host-start.bbappend b/meta-romulus/recipes-phosphor/host/p9-host-start.bbappend
index 4cac490..278470f 100644
--- a/meta-romulus/recipes-phosphor/host/p9-host-start.bbappend
+++ b/meta-romulus/recipes-phosphor/host/p9-host-start.bbappend
@@ -1,3 +1,3 @@
-RDEPENDS_${PN} += 'avsbus-control'
-RDEPENDS_${PN} += 'vrm-control'
-RDEPENDS_${PN}_remove += "p9-vcs-workaround"
+RDEPENDS_${PN}_append_romulus = " avsbus-control"
+RDEPENDS_${PN}_append_romulus = " vrm-control"
+RDEPENDS_${PN}_remove_romulus = "p9-vcs-workaround"