Add Witherspoon thermal policy

Add Witherspoon thermal policy rules for the Witherspoon system.

Do not allow the system to remain running when three or more
POWER9 cores have a temperature of gte 115 degrees C.

Resolves: openbmc/openbmc#1186

Change-Id: Idaf7b78c06de543ada477059867d40df4c86d8c6
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-witherspoon/recipes-phosphor/fans/witherspoon-thermal-policy-native.bb b/meta-witherspoon/recipes-phosphor/fans/witherspoon-thermal-policy-native.bb
new file mode 100644
index 0000000..39831cf
--- /dev/null
+++ b/meta-witherspoon/recipes-phosphor/fans/witherspoon-thermal-policy-native.bb
@@ -0,0 +1,12 @@
+SUMMARY = "Thermal policy for Witherspoon"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-dbus-monitor
+
+SRC_URI += "file://thermal-policy.yaml"
+
+do_install() {
+        install -D ${WORKDIR}/thermal-policy.yaml ${D}${config_dir}/thermal-policy.yaml
+}