phosphor-ipmi-host: Create system-specific hardcoded.yaml file

Witherspoon has 2-rotor fans, while Swift has single-rotor fans.
Move the sensors for the 2nd rotor to a witherspoon yaml file.
In the future, any system-specific sensors can be added to the
witherspoon/swift_hardcoded.yaml file

Tested: Built swift and witherspoon and verified only witherspoon
        had the new witherspoon_hwmon_sensors.hardcoded.yaml in the
        build directory.

Change-Id: Ie9d0719b17eaa6a3e6cb9457deca32f7f727e546
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
diff --git a/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
index e1798ad..5359cc7 100644
--- a/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
+++ b/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -5,6 +5,14 @@
 	file://channel.yaml \
 	"
 
+# System-specific sensors
+SRC_URI_append_witherspoon = " \
+	file://witherspoon_hwmon_sensors.hardcoded.yaml \
+	"
+SRC_URI_append_witherspoon-128 = " \
+	file://witherspoon_hwmon_sensors.hardcoded.yaml \
+	"
+
 EXTRA_OECONF_append = " \
         CHANNEL_YAML_GEN=${WORKDIR}/channel.yaml \
         "