meta-romulus: Add fan control yaml configs

1. The config follows Witherspoon's and remove water-cool/gpu/pcie
related configs.
2. Uses FanPwm interface instead of FanSpeed.
3. Removed zone_condition related config which is optional. Romulus is
always air cooled.
4. Updated to use groups for events.

Tested: Verified that fan control automatically adjust fan speeds based
        on temperatures.

Change-Id: I386c7e921557ef53b445cafe504d2927a76e8e38
Signed-off-by: Lei YU <mine260309@gmail.com>
diff --git a/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config-native.bbappend b/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config-native.bbappend
new file mode 100644
index 0000000..6d4804d
--- /dev/null
+++ b/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config-native.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+