Install witherspoon-reset-fan-watchdog service
This is a witherspoon only service that will
reset the fan watchdog circuit on a poweron, which
would bring the fans out of watchdog control if they
previously were.
The watchdog is reset by toggling a GPIO that feeds
a latch that drives the watchdog signal to the fan
controller. The GPIO parameters are obtained from
an environment file.
The witherspoon-fan-watchdog.bb recipe will have other
watchdog related services added to it in the future.
Resolves openbmc/openbmc#1687
Change-Id: I103ccf6cb69f8a98fc352fa2fa05e45ecbf2cd23
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend b/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
index af3933b..db27edc 100644
--- a/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
+++ b/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
@@ -1 +1,2 @@
RDEPENDS_${PN}-inventory += "openpower-fru-vpd openpower-occ-control phosphor-cooling-type"
+RDEPENDS_${PN}-fan-control += "witherspoon-fan-watchdog"