meta-witherspoon: Add psu.json for phosphor-power

The service psu-monitor in phosphor-power now requires psu.json to
run. Otherwise it fails due to unable to open and parse the JSON file.

Install psu.json for Witherspoon so it works OK.

Tested: On Witherspoon, the psu-monitor services are started correctly,
        and the PSU model, serial, etc are correct in inventory.

Change-Id: I3135a7f75ddd2fb68b5a05409603af6a1d6c3cac
Signed-off-by: Lei YU <mine260309@gmail.com>
diff --git a/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb b/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb
index 49fe344..2625bfc 100644
--- a/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb
+++ b/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb
@@ -11,6 +11,7 @@
 require ${PN}.inc
 
 S = "${WORKDIR}/git"
+SRC_URI += "file://psu.json"
 
 DEPENDS += " \
          phosphor-logging \
@@ -24,6 +25,11 @@
 
 EXTRA_OEMESON += "-Ducd90160-yaml=${STAGING_DIR_HOST}${datadir}/power-sequencer/ucd90160.yaml"
 
+do_install_append(){
+    install -D ${WORKDIR}/psu.json ${D}${datadir}/phosphor-power/psu.json
+}
+FILES_${PN} += "${datadir}/phosphor-power/psu.json"
+
 CHASSIS_ON_TGT = "obmc-chassis-poweron@0.target"
 SEQ_MONITOR_SVC = "pseq-monitor.service"
 SEQ_MONITOR_FMT = "../${SEQ_MONITOR_SVC}:${CHASSIS_ON_TGT}.wants/${SEQ_MONITOR_SVC}"