Add witherspoon inventory associations

Add the inventory association definitions for witherspoon.
With these, phosphor-inventory will create the
org.openbmc.Associations interface on the specified
inventory paths such that the object mapper will create
the association D-Bus objects.

These associations are used to associate inventory paths
to their fans, sensors, and LEDs.

Change-Id: Ib41771e036d24e578abe7e30d0a243388a09b624
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend b/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
new file mode 100644
index 0000000..5e3aff4
--- /dev/null
+++ b/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
@@ -0,0 +1,8 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+PACKAGECONFIG_append = " associations"
+SRC_URI += "file://associations.json"
+
+do_install_append() {
+    install -d ${D}${base_datadir}
+    install -m 0755 ${WORKDIR}/associations.json ${D}${base_datadir}/associations.json
+}