Add u-boot for Palmetto

Ported from http://github.com/facebook/openbmc.
diff --git a/meta-palmetto/recipes-bsp/u-boot/u-boot_2013.07%.bbappend b/meta-palmetto/recipes-bsp/u-boot/u-boot_2013.07%.bbappend
new file mode 100644
index 0000000..6d4a18f
--- /dev/null
+++ b/meta-palmetto/recipes-bsp/u-boot/u-boot_2013.07%.bbappend
@@ -0,0 +1,13 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+#SRC_URI += "file://fw_env.config
+SRC_URI += "file://patch-2013.07/0000-u-boot-aspeed-064.patch \
+           file://patch-2013.07/0001-u-boot-openbmc.patch \
+           file://config.patch \
+           "
+
+# Do not install u-boot in rootfs
+#do_install[postfuncs] += "remove_uboot_from_rootfs"
+#remove_uboot_from_rootfs() {
+#    rm -rf ${D}/boot/u-boot*
+#}