Enable LED support for Romulus

Support for groups bmc_booted, power_on, enclosure_fault,
enclosure_identify, and lamp_test.

Allows lamp test to display all LED colors on a multi color LED
as part of the lamp test.

Notice there is no LED change for Power states.  That is because
the Romulus op panel does not run on standby power.  It is
impossible to do anything useful with the power LED.

Change-Id: Ib60ced92cd3d3da6176a486870640137a7ab08fb
Signed-off-By: Chris Austen <austenc@us.ibm.com>
diff --git a/meta-romulus/recipes-phosphor/leds/romulus-led-manager-config-native.bb b/meta-romulus/recipes-phosphor/leds/romulus-led-manager-config-native.bb
new file mode 100644
index 0000000..fefa84d
--- /dev/null
+++ b/meta-romulus/recipes-phosphor/leds/romulus-led-manager-config-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Phosphor LED Group Management for Romulus"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-utils
+inherit obmc-phosphor-license
+
+PROVIDES += "virtual/phosphor-led-manager-config-native"
+
+SRC_URI += "file://led.yaml"
+S = "${WORKDIR}"
+
+# Overwrite the example led layout yaml file prior
+# to building the phosphor-led-manager package
+do_install() {
+    SRC=${S}
+    DEST=${D}${datadir}/phosphor-led-manager
+    install -D ${SRC}/led.yaml ${DEST}/led.yaml
+}