Get Device ID - JSON for Witherspoon

This is a reference for how to use get device ID with the witherspoon
platform. All other platforms that need get device ID should add
dev_id.json in their own machine specific bbappend files.

Change-Id: I0348748bfb9442d2de43b661cc291663f279efcb
Signed-off-by: David Cobbley <david.j.cobbley@linux.intel.com>
diff --git a/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host.bbappend b/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host.bbappend
index f5b39fc..6c32425 100644
--- a/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host.bbappend
+++ b/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host.bbappend
@@ -1,2 +1,4 @@
 FILESEXTRAPATHS_append_witherspoon := ":${THISDIR}/${PN}"
-SRC_URI_append_witherspoon = " file://occ_sensors.hardcoded.yaml"
+SRC_URI_append_witherspoon = " file://occ_sensors.hardcoded.yaml \
+                               file://dev_id.json \
+                             "