meta-romulus hwmon: Use negative-errno-on-fail config

In phosphor-hwmon, the config "--enable-negative-errno-on-fail" is
introduced for sensors that should return errno instead of failing and
exiting.

Enable this config for Romulus so the fan sensors are working, otherwise
hwmon will fail and exit when fans are not working.

Tested: Verify that the fan_tach sensors return -ETIMEOUT when host is
        powered off and do not exit with failure.

Change-Id: I0d52a2b1a7fb4bf9fc542de6a88823b36bd2bc48
Signed-off-by: Lei YU <mine260309@gmail.com>
diff --git a/meta-romulus/recipes-phosphor/sensors/phosphor-hwmon%.bbappend b/meta-romulus/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
index d5a2ebe..536d797 100644
--- a/meta-romulus/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
+++ b/meta-romulus/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
@@ -1,11 +1,6 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
-# Pin the revision so the patch is guaranteed to be appliable
-# TODO: Remove this when the error handling in hwmon is done:
-# https://gerrit.openbmc-project.xyz/#/c/8073/
-SRCREV = "a23babd6952cb21397d6aa408a827047d1de81de"
-
-SRC_URI += " file://0001-sysfs-Return-ETIMEDOUT-instead-of-throw-exception.patch"
+EXTRA_OECONF_append_romulus = " --enable-negative-errno-on-fail"
 
 CHIPS = " \
         i2c@1e78a000/i2c-bus@440/w83773g@4c \