Add in DPS310 hwmon config file
The DPS310 is a new chip coming soon to provide ambient
temperature to the openbmc. The config file may need
a few tweaks when the chip arrives but this at least
provides a base that will not hurt anything.
Change-Id: Id5264ddcab7245f9ec9b3dbb5898f76ccf45e82b
Signed-off-by: Andrew Geissler <andrewg@us.ibm.com>
diff --git a/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon%.bbappend b/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
index 0a2ba9e..4796f2d 100644
--- a/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
+++ b/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
@@ -1,6 +1,10 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-WSPOON_CHIPS = "i2c@1e78a000/i2c-bus@100/bmp280@77"
+WSPOON_CHIPS = " \
+ i2c@1e78a000/i2c-bus@100/bmp280@77 \
+ i2c@1e78a000/i2c-bus@100/dps310@76 \
+ "
+
WSPOON_ITEMSFMT = "ahb/apb/{0}.conf"
WSPOON_ITEMS = "${@compose_list(d, 'WSPOON_ITEMSFMT', 'WSPOON_CHIPS')}"