sensors:max31785-msl: Enable/install max31785-msl package

The max31785-msl application is now a package within the phosphor-hwmon
recipe, so that package needs to be enabled and installed on
`ibm-ac-server` alias of machines which have a max31785 chip. These
machines require that the minimum ship level(msl) be verified on them
using this application.

Tested:
    Built phosphor-hwmon package after enabling max31785-msl package
    Verified application, config file, and service existed in image

Change-Id: I7ea714dff4bf00b278aacb96d86c7a1f04b60cad
Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
diff --git a/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend b/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
index 6cba853..3eaa70e 100644
--- a/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
+++ b/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
@@ -105,6 +105,8 @@
 SYSTEMD_ENVIRONMENT_FILE_${PN}_append_mihawk = " ${@compose_list(d, 'ENVS', 'ITEMS')}"
 SYSTEMD_ENVIRONMENT_FILE_${PN}_append_mihawk = " ${@compose_list(d, 'ENVS', 'OCCITEMS')}"
 
+# Enable and install the max31785-msl package
+PACKAGECONFIG_append_ibm-ac-server = " max31785-msl"
 SYSTEMD_ENVIRONMENT_FILE_max31785-msl_append_ibm-ac-server = " obmc/hwmon-max31785/max31785.conf"
 SYSTEMD_LINK_max31785-msl_append_ibm-ac-server = " ../phosphor-max31785-msl@.service:multi-user.target.wants/phosphor-max31785-msl@${MACHINE}.service"