phosphor-led-manager: Support LED groups for swift

Change-Id: I5fd0e100b06ca25f1ce02af9251e23151bbaf04d
Signed-off-by: Vishwanatha Subbanna <vishwa@linux.vnet.ibm.com>
diff --git a/recipes-phosphor/leds/swift-led-manager-config-native.bb b/recipes-phosphor/leds/swift-led-manager-config-native.bb
new file mode 100644
index 0000000..459a316
--- /dev/null
+++ b/recipes-phosphor/leds/swift-led-manager-config-native.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Phosphor LED Group Management for Mihawk"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit native
+
+PROVIDES += "virtual/phosphor-led-manager-config-native"
+
+SRC_URI += "file://led.yaml"
+S = "${WORKDIR}"
+
+# Copies example led layout yaml file
+do_install() {
+    SRC=${S}
+    DEST=${D}${datadir}/phosphor-led-manager
+    install -D ${SRC}/led.yaml ${DEST}/led.yaml
+}