fans:monitor:witherspoon: Install config.json file

In prep for switching the witherspoon machine over to using a runtime
fan monitoring JSON configuration, install the configuration file into
the image now.

Tested:
    Verified both `monitor.yaml` and `config.json` in phosphor-fan
    Built/installed witherspoon image and config.json file present
    Verified YAML config still used instead of present JSON config

Change-Id: Icf439c238b4a8cfe16de70ba68819071f6c1ed99
Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
diff --git a/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend b/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
index 8f2097c..9307f17 100644
--- a/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
+++ b/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
@@ -1 +1,14 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+
+SRC_URI_witherspoon += "file://monitor.yaml"
+SRC_URI_witherspoon += "file://config.json"
+
+do_install_append_witherspoon() {
+        DEST=${D}${monitor_datadir}
+        install -D monitor.yaml ${D}${monitor_datadir}/monitor.yaml
+        install -d ${D}/${datadir}/phosphor-fan-presence/monitor/
+        install -m 0644 ${WORKDIR}/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/
+}
+
+FILES_${PN}_witherspoon += "${datadir}/phosphor-fan-presence/monitor/config.json"
+FILES_${PN}_witherspoon += "${monitor_datadir}/monitor.yaml"