fans:monitor:witherspoon: Install config.json file

In prep for switching the witherspoon machine over to using a runtime
fan monitoring JSON configuration, install the configuration file into
the image now.

Tested:
    Verified both `monitor.yaml` and `config.json` in phosphor-fan
    Built/installed witherspoon image and config.json file present
    Verified YAML config still used instead of present JSON config

Change-Id: Icf439c238b4a8cfe16de70ba68819071f6c1ed99
Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
diff --git a/recipes-phosphor/fans/phosphor-fan_%.bbappend b/recipes-phosphor/fans/phosphor-fan_%.bbappend
index 10f3f22..cb89a3a 100644
--- a/recipes-phosphor/fans/phosphor-fan_%.bbappend
+++ b/recipes-phosphor/fans/phosphor-fan_%.bbappend
@@ -58,6 +58,7 @@
 # Enable the use of JSON on the fan applications that support it
 EXTRA_OECONF_append_witherspoon = " --enable-json"
 RDEPENDS_${PN}-presence-tach_append_witherspoon = " phosphor-fan-presence-config"
+RDEPENDS_${PN}-monitor_append_witherspoon = " phosphor-fan-monitor-config"
 
 # Set the appropriate i2c address used within the overridden phosphor-fan-control@.service
 # file that's used for witherspoon type(including witherspoon-tacoma) machines