meta-ibm: acx22: new YAML dependency scheme

A prior patch added a new recipe acx22-yaml-config to provide all the
YAML configuration for ACx22 systems.  This patch switches the layer to
that recipe by setting EXTRA_OECONF and DEPENDS as appropriate in the
required bbappends.

With this switch, a number of recipes and their provided YAML are now
dead metadata, so remove those.

Change-Id: I7b0190986615bc2a66334f125d97a54466a37eb9
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
index bb28054..16b1379 100644
--- a/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
+++ b/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -1,10 +1,7 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI_append = " \
-	file://occ_sensors.hardcoded.yaml \
-	file://hwmon_sensors.hardcoded.yaml \
-	"
+DEPENDS_append = " acx22-yaml-config"
 
-# System-specific sensors
-SRC_URI_append_witherspoon = " \
-	file://witherspoon_hwmon_sensors.hardcoded.yaml \
-	"
+EXTRA_OECONF = " \
+    SENSOR_YAML_GEN=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-sensors.yaml \
+    INVSENSOR_YAML_GEN=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-inventory-sensors.yaml \
+    FRU_YAML_GEN=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-fru-read.yaml \
+    "