meta-romulus: Add inventory-cleanup.yaml

The yaml add the "xyz.openbmc_project.Inventory.Item.Chassis" interface
to "/xyz/openbmc_project/inventory/system/chassis" object.

This is needed for bmcweb to correctly get the chassis id in
/redfish/v1/Chassis/.

Tested: Verify that /redfish/v1/Chassis/chassis exists on Romulus with
        this change. It was 404 without this change.

Signed-off-by: Lei YU <mine260309@gmail.com>
Change-Id: Ie35bfd67fb02484565c8a8a6189a0779569e93a7
diff --git a/meta-romulus/recipes-phosphor/inventory/inventory-cleanup.bb b/meta-romulus/recipes-phosphor/inventory/inventory-cleanup.bb
new file mode 100644
index 0000000..0c4b56f
--- /dev/null
+++ b/meta-romulus/recipes-phosphor/inventory/inventory-cleanup.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Copy the inventory cleanup yaml for inventory manager"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit allarch
+inherit phosphor-inventory-manager
+
+S = "${WORKDIR}"
+
+SRC_URI = "file://inventory-cleanup.yaml"
+
+do_install() {
+        install -D inventory-cleanup.yaml ${D}${base_datadir}/events.d/inventory-cleanup.yaml
+}
+
+FILES_${PN} += "${base_datadir}/events.d/inventory-cleanup.yaml"