swift: Add si7021a20 ambient sensor

Swift has 3 ambient temperature sensors, the si7021a20 will be labeled
as `ambient2` and initially use the same warn/crit temperature
configurations as Witherspoon.

Tested:
    Built image that contained the config file

Change-Id: I6c5e9924c2204113e1caa6109b48142321f449c7
Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
diff --git a/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend b/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
index c5d75a7..dfd992b 100644
--- a/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
+++ b/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
@@ -26,6 +26,7 @@
                bus@1e78a000/i2c-bus@440/tmp275@48 \
                bus@1e78a000/i2c-bus@300/tmp275@48 \
                bus@1e78a000/i2c-bus@300/dps310@76 \
+               bus@1e78a000/i2c-bus@300/si7021a20@20 \
                "
 
 ITEMSFMT = "ahb/apb/{0}.conf"