meta-ibm: rainier: install dump header script

This commit will install the dump header script which
will create dump header and impose the same
on the dump.tar.xz file.

Header format will consist of the following:
-virtual file directory entry:
one file directory entry for BMC DUMP, which will have
file header and size of 40 bytes which consists of
system serial number, dump identifier, time stamp
of the dump.

-section directory entry:
This has SECTION as entry header, size is of 30 bytes
consists of total size of the dump along with other
details.

-dump header:
This has an eye catcher "BMC DUMP", dump
identifier, system serial number, system name etc.

-dump data table:
This will have dump version, dump valid
field and number of dump entries.

Change-Id: I3f00c5cfa1cba32f90801aff475a0f2ab54148c1
Signed-off-by: Chirag Sharma <chirshar@in.ibm.com>
diff --git a/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend b/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
index 91ef83e..194d66c 100644
--- a/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
+++ b/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
@@ -24,5 +24,13 @@
     install_dreport_user_script(script, d)
 }
 
-do_install[postfuncs] += "install_ibm_plugins"
-do_install[postfuncs] += "link_ibm_plugins"
+#Install dump header script from dreport/ibm.d to dreport/include.d
+install_dreport_header() {
+    install -d ${D}${dreport_include_dir}
+    install -m 0755 ${S}/tools/dreport.d/ibm.d/* ${D}${dreport_include_dir}/
+}
+
+IBM_INSTALL_POSTFUNCS = "install_ibm_plugins link_ibm_plugins"
+IBM_INSTALL_POSTFUNCS_rainier += "install_dreport_header"
+
+do_install[postfuncs] += "${IBM_INSTALL_POSTFUNCS}"