meta-ibm: Add the ncsi-netlink service for mihawk

Prevent the BMC from failing over to the other ethernet port if it
detects a network drop on the one it's using.

Signed-off-by: Ben Pai <Ben_Pai@wistron.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Change-Id: I258e524b13b53cd2de3e3e4001b0475d22f26434
diff --git a/meta-witherspoon/recipes-phosphor/network/phosphor-network_%.bbappend b/meta-witherspoon/recipes-phosphor/network/phosphor-network_%.bbappend
index ba6e393..bcb2d01 100644
--- a/meta-witherspoon/recipes-phosphor/network/phosphor-network_%.bbappend
+++ b/meta-witherspoon/recipes-phosphor/network/phosphor-network_%.bbappend
@@ -1,8 +1,15 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/network:"
 SRC_URI_append_ibm-ac-server = " file://ncsi-netlink.service"
+SRC_URI_append_mihawk = " file://ncsi-netlink.service"
+
 SYSTEMD_SERVICE_${PN}_append_ibm-ac-server = " ncsi-netlink.service"
+SYSTEMD_SERVICE_${PN}_append_mihawk = " ncsi-netlink.service"
 
 do_install_append_ibm-ac-server() {
     install -d ${D}${systemd_system_unitdir}
     install -m 0644 ${WORKDIR}/ncsi-netlink.service ${D}${systemd_system_unitdir}
 }
+do_install_append_mihawk() {
+    install -d ${D}${systemd_system_unitdir}
+    install -m 0644 ${WORKDIR}/ncsi-netlink.service ${D}${systemd_system_unitdir}
+}