Move Rainier and Witherspoon-tacoma to Vue GUI

Leave the rest of the IBM AC Servers on phosphor-webui since things like
two file firmware update and Virtual Media are not currently supported on
webui-vue.

The hope is in the near future to move all IBM Servers to webui-vue,
including all ibm-ac-servers (e.g. Witherspooon).

webui-vue is a complete rewrite of phosphor-webui. It uses the Redfish
API, is translatable, themeable, does not suffer some the  anti-patterns that
exist in phosphor-webui today and is built on Vue.

phosphor-webui was built on AngularJS and AngularJS goes End of Life June 2021.

Huge shoutout to the team here, webui-vue is an impressive GUI!

Tested: Built Witherspoon, see the AngularJS GUI.
        Built witherspoon-tacoma see the Vue GUI.
Change-Id: Ieb1ae212970c218cd3417c89e85bf614afd11cfa
Signed-off-by: Gunnar Mills <gmills@us.ibm.com>
diff --git a/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend b/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
index e7e0df3..3a322d8 100644
--- a/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
+++ b/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
@@ -24,16 +24,16 @@
 RDEPENDS_${PN}-fan-control_append_ibm-ac-server = " fan-watchdog"
 RDEPENDS_${PN}-fan-control_append_rainier = " fan-watchdog"
 RDEPENDS_${PN}-extras_append_ibm-ac-server = " ${POWER_SERVICE_PACKAGES_AC_SERVER} witherspoon-power-supply-sync phosphor-webui"
-RDEPENDS_${PN}-extras_append_rainier = " ${POWER_SERVICE_PACKAGES_RAINIER} phosphor-webui"
+RDEPENDS_${PN}-extras_append_rainier = " ${POWER_SERVICE_PACKAGES_RAINIER} webui-vue"
 RDEPENDS_${PN}-extras_append_mihawk = " phosphor-webui phosphor-image-signing wistron-ipmi-oem ${POWER_SERVICE_PACKAGES_AC_SERVER}"
+RDEPENDS_${PN}-extras_append_witherspoon-tacoma = " pldm srvcfg-manager webui-vue"
+
 RDEPENDS_${PN}-extras_remove_rainier = "obmc-ikvm liberation-fonts uart-render-controller"
 RDEPENDS_${PN}-extras_remove_swift = "obmc-ikvm"
-RDEPENDS_${PN}-extras_remove_witherspoon-tacoma = "obmc-ikvm liberation-fonts uart-render-controller"
+RDEPENDS_${PN}-extras_remove_witherspoon-tacoma = "obmc-ikvm liberation-fonts uart-render-controller phosphor-webui"
 RDEPENDS_${PN}-logging_append = " ${EXTRA_IBM_LOGGING_PKGS}"
 RDEPENDS_${PN}-extras_append_rainier = " pldm openpower-hw-diags srvcfg-manager"
 RDEPENDS_${PN}-leds_remove_rainier = "phosphor-led-manager-faultmonitor"
 RDEPENDS_${PN}-leds_remove_witherspoon-tacoma = "phosphor-led-manager-faultmonitor"
 
-RDEPENDS_${PN}-extras_append_witherspoon-tacoma = " pldm srvcfg-manager"
-
 ${PN}-software-extras_append_ibm-ac-server = " phosphor-software-manager-sync"