meta-ibm: use machine overrides instead of distro

Using a distro feature here might be a case of too much abstraction.
Instead, just enable them because that is what is desired for those
systems.  This is slightly easier to comprehend.

Revisit, if at a later time, several phosphor-software-manager users
enable signature verification and file syncing when using UBI (making
the abstraction useful).  If/when that occurs, those configure options
and packages should be enabled via the distro feature in the base
recipe and not in a bbappend.

Change-Id: I34400a0d7de01ac7557e05fdbb94325bbfdefc14
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-witherspoon/recipes-phosphor/flash/phosphor-software-manager_%.bbappend b/meta-witherspoon/recipes-phosphor/flash/phosphor-software-manager_%.bbappend
index b58fc3b..13c434d 100644
--- a/meta-witherspoon/recipes-phosphor/flash/phosphor-software-manager_%.bbappend
+++ b/meta-witherspoon/recipes-phosphor/flash/phosphor-software-manager_%.bbappend
@@ -2,8 +2,10 @@
 BMC_RO_MTD = "alt-bmc+bmc"
 BMC_KERNEL_MTD = "bmc"
 
-# Enable signature verification by DISTRO_FEATURE obmc-ubi-fs
-PACKAGECONFIG_append_df-obmc-ubi-fs = " verify_signature"
+# Enable signature verification
+PACKAGECONFIG_append_witherspoon = " verify_signature"
+PACKAGECONFIG_append_swift = " verify_signature"
 
 # Enable sync of persistent files to the alternate BMC chip
-PACKAGECONFIG_append_df-obmc-ubi-fs = " sync_bmc_files"
+PACKAGECONFIG_append_witherspoon = " sync_bmc_files"
+PACKAGECONFIG_append_swift = " sync_bmc_files"