meta-ibm: use machine overrides instead of distro

Using a distro feature here might be a case of too much abstraction.
Instead, just enable them because that is what is desired for those
systems.  This is slightly easier to comprehend.

Revisit, if at a later time, several phosphor-software-manager users
enable signature verification and file syncing when using UBI (making
the abstraction useful).  If/when that occurs, those configure options
and packages should be enabled via the distro feature in the base
recipe and not in a bbappend.

Change-Id: I34400a0d7de01ac7557e05fdbb94325bbfdefc14
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend b/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
index 6e0db1e..92b48f9 100644
--- a/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
+++ b/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
@@ -2,4 +2,5 @@
 RDEPENDS_${PN}-fan-control += "witherspoon-fan-watchdog"
 RDEPENDS_${PN}-extras += "witherspoon-pfault-analysis witherspoon-power-supply-sync phosphor-webui"
 
-${PN}-software-extras_df-obmc-ubi-fs += "phosphor-software-manager-sync"
+${PN}-software-extras_append_witherspoon = " phosphor-software-manager-sync"
+${PN}-software-extras_append_swift = " phosphor-software-manager-sync"