meta-romulus: add occ-control-config-native

openpower-occ-control requires a sensor header file generated from
occ_sensor.yaml. By default it uses an example yaml, which does not fit
for Romulus.

Add romulus-occ-control-config-native.bb to use its own
occ_sensor.yaml, so that the package uses the correct config.

Tested: Verify the build uses the correct config generated from
        Romulus's occ_sensor.yaml.

Change-Id: Iadf1e54e5b26865a029b39a60b8412bb4a13c1a7
Signed-off-by: Lei YU <mine260309@gmail.com>
diff --git a/meta-romulus/recipes-phosphor/occ/romulus-occ-control-config-native.bb b/meta-romulus/recipes-phosphor/occ/romulus-occ-control-config-native.bb
new file mode 100644
index 0000000..ec6a39d
--- /dev/null
+++ b/meta-romulus/recipes-phosphor/occ/romulus-occ-control-config-native.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Romulus OCC Control sensor IDs"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit native
+inherit openpower-occ-control
+
+SRC_URI += "file://occ_sensor.yaml"
+
+PROVIDES += "virtual/openpower-occ-control-config-native"
+
+S = "${WORKDIR}"
+
+do_install() {
+    install -d ${YAML_DEST}/
+    install -D occ_sensor.yaml ${YAML_DEST}/occ_sensor.yaml
+}