Add Witherspoon Power Supply policy

Create an error if a power supply is removed
while the system is powered on

Resolves openbmc/openbmc#1860

Change-Id: I7456505bb16771e9fd6edad9ebf6c28dbd0b7824
Signed-off-by: Gunnar Mills <gmills@us.ibm.com>
diff --git a/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-policy-native.bb b/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-policy-native.bb
new file mode 100644
index 0000000..4d234c1
--- /dev/null
+++ b/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-policy-native.bb
@@ -0,0 +1,12 @@
+SUMMARY = "Power supply policy for Witherspoon"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-dbus-monitor
+
+SRC_URI += "file://power-supply-policy.yaml"
+
+do_install() {
+        install -D ${WORKDIR}/power-supply-policy.yaml ${D}${config_dir}/power-supply-policy.yaml
+}