Create Palmetto inventory recipe.

Create a recipe that will install Palmetto's inventory
file into the flash image.  This is mostly a proof of
concept to show how the inventory could be data driven.
A future commit will update inventory_manager.py to use it.
Eventually, this file will be auto generated from the machine
readable workbook.

Change-Id: I2723ff0dbc25807561ca3f9355ccfb64353119e5
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-palmetto/recipes-phosphor/workbook/palmetto-inventory.bb b/meta-palmetto/recipes-phosphor/workbook/palmetto-inventory.bb
new file mode 100644
index 0000000..0133c87
--- /dev/null
+++ b/meta-palmetto/recipes-phosphor/workbook/palmetto-inventory.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Palmetto System Inventory"
+DESCRIPTION = "Provides the inventory file for Palmetto"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit allarch
+
+RPROVIDES_${PN} = "virtual-system-inventory-data"
+
+SRC_URI += "file://palmetto_inventory.json"
+
+FILES_${PN} += "${datadir}/inventory"
+
+do_install() {
+    install -d ${D}${datadir}/inventory
+    install -m 0644 palmetto_inventory.json ${D}${datadir}/inventory/inventory.json
+}
+
+S = "${WORKDIR}"