ipmi: Remove virtual/phosphor-ipmi-fru-config

Replace this virtual with two others:
 -virtual/phosphor-ipmi-fru-hostfw-config
 -virtual/phosphor-ipmi-fru-inventory.

Update ipmi-fru-parser machine recipes to provide
virtual/phosphor-ipmi-fru-inventory rather than
virtual/phosphor-ipmi-fru-config.

Remove machine recipes on machines that use MRW
since a single MRW recipe provides for any MRW
using system automatically.

Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com?
Change-Id: Ia0d94b938eb2c7bfadd5a018ae5ea136f14dd874
diff --git a/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map-native.bb b/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map-native.bb
new file mode 100644
index 0000000..2b5348a
--- /dev/null
+++ b/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map-native.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Palmetto IPMI to DBus Inventory mapping."
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-ipmi-fru
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
+
+S = "${WORKDIR}"
+
+do_install() {
+        # TODO: install this to inventory_datadir
+        # after ipmi-fru-parser untangles the host
+        # firmware config from the machine inventory.
+        DEST=${D}${config_datadir}
+
+        install -d ${DEST}
+        install config.yaml ${DEST}
+}
+