disable warm reboot on romulus

Similar to commit 567a8d for witherspoon, this issue has now popped
up on Romulus hardware.

The concept of warm reboot (reboot the host without removing chassis
power) was added a while back as a part of clarifying support for
the Redfish ComputerSystem.Reset Action. It has since been found that
some IBM hardware, including Romulus, do not support warm reboots.
The issue is intermittent and depends on the reboot being requested
while the host is in the middle of some i2c transactions. If a warm
reboot occurs during this window, then on the subsequent boot the i2c
hardware will be in a bad state and the host firmware is unable to
recover it.

Given this issue, it has been requested that BMC software go back to
doing cold reboots (cycling power to the chassis during any reboot
request) on this hardware.

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: Ie25d4c7be191f1ffd25f19261645ad6f2ff566b7
diff --git a/meta-romulus/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-romulus/recipes-phosphor/state/phosphor-state-manager_%.bbappend
index 4db6f3a..308c731 100644
--- a/meta-romulus/recipes-phosphor/state/phosphor-state-manager_%.bbappend
+++ b/meta-romulus/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -1 +1,3 @@
 FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${PN}:"
+
+EXTRA_OEMESON_romulus += "-Dwarm-reboot=disabled"