webui: serve via nginx

Serve the mostly pre-compressed static webui content via nginx. If nginx
can't find a static file, proxy the URI back to the rest server.

A follow-up commit will remove code that serves webui from the
phosphor-rest-server.

Tested:
- The webui, rest server and bmcweb seem to be working as before.
- curl -H "Accept-Encoding: gzip" https://<witherspoon>/foo.html
  is served compressed content.
- curl https://<witherspoon>/foo.html is served uncompressed
  content.

Change-Id: Ice443f00a467f3558f28d697261df4f23278f420
Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
diff --git a/recipes-httpd/nginx/nginx_%.bbappend b/recipes-httpd/nginx/nginx_%.bbappend
index 8a58341..8eb7e40 100644
--- a/recipes-httpd/nginx/nginx_%.bbappend
+++ b/recipes-httpd/nginx/nginx_%.bbappend
@@ -9,7 +9,7 @@
     file://gen-cert.sh \
     "
 
-EXTRA_OECONF =+ " --without-select_module"
+EXTRA_OECONF =+ " --without-select_module --with-http_gunzip_module"
 
 SSLCERTPATH = "/etc/ssl/certs/nginx/"