Add Witherspoon fan policy

Add Witherspoon fan plug policy rules for the Witherspoon system.

An air cooled Witherspoon requires a minimum of three functional fans.
If the number of functional fans drops below that for longer than five
seconds power the system off.

A water cooled Witherspoon requires a minimum of two functional fans.
If the number of functional fans drops below that for longer than five
seconds power the system off.

Change-Id: I0bba905dcd7542c43215a051e2df2c87fefce154
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-policy-native.bb b/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-policy-native.bb
new file mode 100644
index 0000000..c2e843f
--- /dev/null
+++ b/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-policy-native.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Fan policy for Witherspoon"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-dbus-monitor
+
+SRC_URI += "file://air-cooled.yaml"
+SRC_URI += "file://water-cooled.yaml"
+
+do_install() {
+        install -D ${WORKDIR}/air-cooled.yaml ${D}${config_dir}/air-cooled.yaml
+        install -D ${WORKDIR}/water-cooled.yaml ${D}${config_dir}/water-cooled.yaml
+}