witherspoon: Remove `witherspoon` naming from fan watchdog

Remove the use of `witherspoon` in the names of the recipe, config
files, and services of the fan watchdog. This is in prep to use this
same fan watchdog on other machines within meta-ibm that have different
configurations.

Tested:
    Witherspoon image matches image prior to change
    Flash image to Witherspoon and force watchdog to trip

Change-Id: I86f37921410e0b0c5a318b8aef19c8e0b2774f45
Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
diff --git a/recipes-phosphor/fans/fan-watchdog.bb b/recipes-phosphor/fans/fan-watchdog.bb
new file mode 100644
index 0000000..d71b378
--- /dev/null
+++ b/recipes-phosphor/fans/fan-watchdog.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Fan watchdog services"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit obmc-phosphor-systemd
+
+RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
+RDEPENDS_${PN} += "busybox"
+
+RESET_SERVICE = "reset-fan-watchdog.service"
+TGTFMT = "obmc-chassis-poweron@0.target"
+RESET_FMT = "../${RESET_SERVICE}:${TGTFMT}.requires/${RESET_SERVICE}"
+
+MONITOR_SERVICE = "fan-watchdog-monitor@.service"
+
+WATCHDOG_SERVICE = "fan-watchdog.service"
+WATCHDOG_FMT = "../${WATCHDOG_SERVICE}:${TGTFMT}.requires/${WATCHDOG_SERVICE}"
+
+SYSTEMD_SERVICE_${PN} += "${RESET_SERVICE} ${MONITOR_SERVICE} ${WATCHDOG_SERVICE}"
+SYSTEMD_LINK_${PN} += "${RESET_FMT} ${WATCHDOG_FMT}"
+SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/fan-watchdog/reset-fan-watchdog.conf"
+SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/fan-watchdog/fan-watchdog.conf"