meta-ibm: wspoon: network: add explicit install append

Add an explicit install_append for the network recipe so it'll install a
service that witherspoon requires.

Note: This change required due to a change in network_git.bb that
changed the systemd installation behavior.

Change-Id: I0d1a8307dc71a7fdd379d26ce77e3d8cff5e5b20
Signed-off-by: Patrick Venture <venture@google.com>
diff --git a/meta-witherspoon/recipes-phosphor/network/network_%.bbappend b/meta-witherspoon/recipes-phosphor/network/network_%.bbappend
index 7e0dc2f..40a0567 100644
--- a/meta-witherspoon/recipes-phosphor/network/network_%.bbappend
+++ b/meta-witherspoon/recipes-phosphor/network/network_%.bbappend
@@ -1,2 +1,8 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+SRC_URI += "file://ncsi-netlink.service"
 SYSTEMD_SERVICE_${PN} += "ncsi-netlink.service"
+
+do_install_append() {
+    install -d ${D}${systemd_system_unitdir}
+    install -m 0644 ${WORKDIR}/ncsi-netlink.service ${D}${systemd_system_unitdir}
+}