meta-witherspoon: Use phosphor-power recipe

phosphor-power recipe is added in meta-phosphor, replace
witherspoon-pfault-analysis with phosphor-power.

Add "psuDevices" in psu.json for witherspoon and swift.

Tested: Verify witherspoon build is OK, the phosphor-power related
        binaries and the services are installed correctly.

Change-Id: I561dc421167cbd2018df8a86c046545c7c86fa0a
Signed-off-by: Lei YU <mine260309@gmail.com>
diff --git a/meta-witherspoon/recipes-phosphor/power/phosphor-power_%.bbappend b/meta-witherspoon/recipes-phosphor/power/phosphor-power_%.bbappend
new file mode 100644
index 0000000..b90dc9b
--- /dev/null
+++ b/meta-witherspoon/recipes-phosphor/power/phosphor-power_%.bbappend
@@ -0,0 +1,15 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://psu.json"
+
+EXTRA_OEMESON += "-Ducd90160-yaml=${STAGING_DIR_HOST}${datadir}/power-sequencer/ucd90160.yaml"
+
+DEPENDS += " power-sequencer"
+
+do_install_append(){
+    install -D ${WORKDIR}/psu.json ${D}${datadir}/phosphor-power/psu.json
+}
+FILES_${PN} += "${datadir}/phosphor-power/psu.json"
+
+PSU_MONITOR_ENV_FMT = "obmc/power-supply-monitor/power-supply-monitor-{0}.conf"
+SYSTEMD_ENVIRONMENT_FILE_${PN} += "${@compose_list(d, 'PSU_MONITOR_ENV_FMT', 'OBMC_POWER_SUPPLY_INSTANCES')}"